Sprievodcovia

Oprava: .NET Framework 4.7 nie je v tomto operačnom systéme podporovaný

.Net Framework je programová infraštruktúra zavedená spoločnosťou Microsoft. Na spustenie rôznych aplikácií a služieb budete potrebovať .Net Framework. Väčšina aplikácií, ktoré vyžadujú .Net Framework, je dodávaná tiež s inštalačnými súbormi. Takže sa automaticky nainštaluje do vášho systému pri inštalácii aplikácie. Pri inštalácii aplikácie sa vám však môže zobraziť chyba „.NET Framework 4.7 nie je v tomto operačnom systéme podporovaný“. Táto chyba vám zabráni v úspešnej inštalácii aplikácie. Táto chyba sa môže zobraziť pri pokuse o inštaláciu .Net Framework ako samostatnej aplikácie / služby.

Dôvod, prečo sa táto chyba stane, je rovnaký, ako je uvedený v chybovom hlásení. Aj keď je .Net Framework podporovaný v systéme Windows 10, ale nie je kompatibilný so všetkými verziami systému Windows 10. Takže ak sa vám zobrazuje táto správa, najpravdepodobnejšou príčinou tejto chyby je to, že používate verziu Windows 10, ktorá nie je kompatibilný s .Net Framework.

Metóda 1: Aktualizácia systému Windows 10

Jediným riešením tohto problému je jednoduchá aktualizácia systému Windows 10. Odporúča sa skontrolovať dostupnosť aktualizácií systému Windows, aj keď používate najnovšiu verziu systému Windows 10. Pretože problém je spôsobený nekompatibilným operačným systémom, inštalácia všetkých dostupných systémov Windows 10 aktualizácie s najväčšou pravdepodobnosťou problém vyriešia. Môžete tiež skontrolovať presnú verziu vášho Windows 10 a verziu požadovanú .Net Framework podľa pokynov uvedených nižšie.

  1. Vydrž Kláves Windows a stlačte R
  2. Typ víťaz a stlačte Zadajte

  1. Vaša verzia by mala byť uvedená v novootvorenom okne. Číslo za verziou (v druhom riadku) je číslo vašej verzie. Číslo by malo byť 1507 alebo 1709. Prvé dve číslice sú rok a druhá dvojica predstavuje mesiac. Ak teda máte verziu 1709, znamená to, že používate verziu vydanú september 2017

  1. Teraz sa musíte ubezpečiť, že máte verziu Windows 10 kompatibilnú s .Net Framework. Kliknite tu a kliknite na ikonu Požiadavky na systém

Ak sa pozriete na Podporovaný operačný systém časť, píše sa Windows 10 Anniversary Update a Aktualizácia Windows 10 Creators. Pretože veľa ľudí nevie o číslach verzií spojených s aktualizáciami Anniversary a Creators, spomenuli sme ich nižšie

  • Novembrová aktualizácia (1511)
  • Aktualizácia k výročiu (14393)
  • Aktualizácia autorov (1703)
  • Aktualizácia Fall Creators (1709)
  • Aktualizácia jarných autorov (1803)

Ako vidíte, Anniversary Update má číslo verzie 14393 a Creators Update verziu 1703. Takže ak máte verziu nižšiu ako 14393, nebudete si môcť nainštalovať .Net Framework 4.7 na Windows 10. Teraz jednoducho aktualizujte Windows, uistite sa, že máte najnovšiu verziu Windows 10, a skúste to znova.